Opened 6 years ago

Closed 6 years ago

#25 closed bug (invalid)

HTMLView 13.4 crash with MUI4 RC3

Reported by: Samir Hawamdeh Owned by:
Priority: undecided Milestone:
Component: foreign application Version: 4.0-2014R3
Severity: minor Keywords:
Cc: OS Platform: AmigaOS4
Blocked By: Blocking:
Release Notes:

Description

The HTMLView 13.4 MUI class will crash when you open it from the MUI4 preferences, this issue happen on MUI4 RC3 but not in the previews version

To preproduce it just open your MUI4 prefs and then select the HTMLView class

Attachments (1)

Crashlog_MUI_2014-03-18_20-23-04.txt (27.7 KB) - added by Samir Hawamdeh 6 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 50 years ago by Samir Hawamdeh

Status: pendingnew

Changed 6 years ago by Samir Hawamdeh

comment:1 Changed 6 years ago by Thore Böckelmann

The crash does not happen within MUI but within intuition.library. The code is called from the HTMLview.mcp dispatcher. There is nothing I can do about that.

Does this happen with 2014R1 or 2014R2 as well?

comment:2 Changed 6 years ago by Samir Hawamdeh

@Thore

Yes Thore, for sure it worked on 2014RC1 version, i know because i use the class with the half functional AmRSS program when i remember to have also changed a few parameters for it (from MUI prefs), so for sure more or less it worked before.
Didn't test it with the RC2, but now in RC3 it crash just when if i try to open it :-(

comment:3 Changed 6 years ago by Thore Böckelmann

Then please test again with R2.

comment:4 Changed 6 years ago by Thore Böckelmann

Status: newpending

I just tried with R3 myself and for me everything is working perfectly. It tried with and without MUNGE kernel option.

comment:5 Changed 6 years ago by Roman Kargin

Tested on my peg2 (HTMLView class from os4depot), with latest beta i have + muimaster.library from ticket#23 : no crash (i am on latest beta + debug.kernel + munge).

comment:6 Changed 6 years ago by Samir Hawamdeh

@Thore & kas1e

Retested now with all MUI versions (R1, R2 and R3) and with all versions i have the same DSI crash now (if i ignore it, then i got an ISI one).
As it still working fine for both of you the only solution is that i might have a specific problem on my system, but what ?

I really don't know where to point of, but i'm sure that even on my system it worked fine

comment:7 Changed 6 years ago by Samir Hawamdeh

Found the issue!

During the various MUI installations it seems that the HotkeyStrings.mcc class were cancelled, but without it HTMLView class stop working and give me a crash.

So yes at the end it was my fault so then you can close the ticket.. sorry guys :-)

comment:8 Changed 6 years ago by Thore Böckelmann

Component: undefinedforeign application
Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.