Opened 4 years ago

Closed 4 years ago

#242 closed bug (worksforme)

Strange width behaviour changes between MUI 20.6421 & MUI 20.6445

Reported by: Guillaume Boesel Owned by:
Priority: normal Milestone: 4.0-2015R3
Component: Register.mui Version: 4.0-nightly build
Severity: minor Keywords:
Cc: OS Platform: AmigaOS4
Blocked By: Blocking:
Release Notes:

Description

* I opened another ticket but forgot to add attachment, please delete the previous one *

Summary

Under MUI 20.6421, no width problem (see MUI_20.6424.JPG)

Under MUI 20.6445, the same tab width is very very large and I'm unable to reduce it.
The 2 others tabs of this window don't have width problem but as soon as I open once the second tab (the one with width problem), the width of all tabs is very very big.
(see MUI_20.6445.JPG)

Steps to reproduce

  1. Open FastView Preferences tab under 20.6445

Expected results

Works as under MUI 20.6421

Notes

This ticket is opened just to ask if you know which MUI elements could have been changed that could explain my problem ?

Thank you very much
Guillaume

Attachments (2)

MUI_20.6424.JPG (129.1 KB) - added by Guillaume Boesel 4 years ago.
MUI_20.6445.JPG (404.6 KB) - added by Guillaume Boesel 4 years ago.

Download all attachments as: .zip

Change History (8)

Changed 4 years ago by Guillaume Boesel

Attachment: MUI_20.6424.JPG added

Changed 4 years ago by Guillaume Boesel

Attachment: MUI_20.6445.JPG added

comment:1 Changed 4 years ago by Guillaume Boesel

Sorry, I was not using the same program version.

When using the same version, same width problem under 20.6424 & 20.6445.

I have to review my code…

Sorry for this ticket.

comment:2 Changed 4 years ago by Guillaume Boesel

Problem solved.

I was still using a RegisterGroup for this window.
Simply switching to Title Object without other changes solved my problem.

comment:3 Changed 4 years ago by Thore Böckelmann

Good to hear the solution was so easy. But it is still a bit puzzling for me that the old Register class should be responsible for the issue. Your second screenshot just shows a partial window. Have you been able to resize the window or was it suddenly fixed sized?

Don't get me wrong, but having to change classes to fix an issue is not the correct solution for me. Maybe it is for you, but I need to know why Register class is suddenly misbehaving. Lots of old applications use this class and it would be a disaster if they suddenly cause such unintended behaviour.

comment:4 Changed 4 years ago by Guillaume Boesel

"Your second screenshot just shows a partial window. Have you been able to resize the window or was it suddenly fixed sized?"
It's a partial screenshot but the window was complete and UNresizable, fixed sized as soon that it was opened.

In my code, I really just modified this

[code]
	const char *Onglets[] = {GetCatalogStr(catalog,MSG_Prefs_Onglet_Options,MSG_Prefs_Onglet_Options_STR), 
				 GetCatalogStr(catalog,MSG_Prefs_Onglet_Capture,MSG_Prefs_Onglet_Capture_STR), 
				 GetCatalogStr(catalog,MSG_Prefs_Onglet_SinglePicture,MSG_Prefs_Onglet_SinglePicture_STR), 
				 NULL };	

  	
	
	Child, RegisterGroup(Onglets), MUIA_Register_Frame, TRUE,		
		...
	End,
[/code]

to

[code]
	
    Child, HGroup,
	Child, TitleObject, MUIA_Title_Closable, FALSE, MUIA_Title_Sortable, TRUE,																																						
	       Child, TextObject,
			MUIA_Text_Contents, GetCatalogStr(catalog,MSG_Prefs_Onglet_Options,MSG_Prefs_Onglet_Options_STR),
			MUIA_Text_SetMin, FALSE,MUIA_Text_SetMax, FALSE,
	       End,
	       Child, TextObject,
			MUIA_Text_Contents, GetCatalogStr(catalog,MSG_Prefs_Onglet_Capture,MSG_Prefs_Onglet_Capture_STR),
			MUIA_Text_SetMin, FALSE,MUIA_Text_SetMax, FALSE,
	       End,
	       Child, TextObject,
			MUIA_Text_Contents, GetCatalogStr(catalog,MSG_Prefs_Onglet_SinglePicture,MSG_Prefs_Onglet_SinglePicture_STR),
			MUIA_Text_SetMin, FALSE,MUIA_Text_SetMax, FALSE,
	       End,	
	End,

	...
   End,

comment:5 Changed 4 years ago by Guillaume Boesel

Note that ONLY the second tab had this problem on my 3 tabs window.

comment:6 Changed 4 years ago by Thore Böckelmann

Component: undefinedRegister.mui
Priority: undecidednormal
Resolution: worksforme
Status: newclosed

I really have clue why such a change should cure the effects. Basically internally MUI's Register class creates the tabs exactly like you do, hence it is absolutely not obvious why your code should behave differently. Furthermore there are lots of other (old) applications which still use Register class instead of Title class and none of these exhibits such a strange behaviour.

Anyway, good to hear this is fixed. Please reopen this ticket if this issue should arise again. We really need to look more deeply at the details then.

Note: See TracTickets for help on using tickets.