Opened 12 months ago

Closed 11 months ago

Last modified 12 days ago

#23 closed bug (fixed)

GR with IBrowse

Reported by: Kenwilde Owned by: tboeckel
Priority: normal Milestone: 4.0-2014R4
Component: Window.mui Version: 4.0-2014R3
Severity: blocker Keywords:
Cc: Kenwilde, Severin OS Platform: AmigaOS4
Blocked By: Blocking:
Release Notes:

Reverted the simplification of a list iteration which caused Odyssey and IBrowse to crash.

Description

Summary

Steps to reproduce

1.Start IB, it will GR after a short period of time, if not, clicking on a fast link or a forum post will.
2.Happens on the X1000 & SAM440

Expected results

Actual results

Regression

Notes

Attachments (9)

ibrowse_crash.txt (4.0 KB) - added by kas1e 12 months ago.
Crashlog_IB_2014-03-17_12-14-39.txt (3.5 KB) - added by Kenwilde 12 months ago.
odyssey_isra_crash.txt (5.1 KB) - added by kas1e 12 months ago.
muimaster_20_6181.lha (356.3 KB) - added by tboeckel 11 months ago.
muimaster.library 20.6181
Crashlog_IBrowse_2014-03-21_04-16-51.txt (36.9 KB) - added by Severin 11 months ago.
Crashlog_IBrowse_2014-03-24_17-35-51a.txt (3.9 KB) - added by Severin 11 months ago.
muimaster_20_6184.lha (356.2 KB) - added by tboeckel 11 months ago.
muimaster.library 20.6184
Crashlog_IBrowse_2014-04-01_21-48-04.txt (3.9 KB) - added by Severin 11 months ago.
muimaster.library 20.6184 crashlog
muimaster_20_6185.lha (356.1 KB) - added by tboeckel 11 months ago.
muimaster.library 20.6185

Download all attachments as: .zip

Change History (44)

comment:1 Changed 12 months ago by tboeckel

  • Status changed from new to pending

Who created this report? Please log in before creating tickets. And where is the crashlog? Without crashlog I cannot tell whether this is a MUI bug or an IBrowse bug.

comment:2 Changed 12 months ago by kas1e

@Thore
As seems initial poster will not make it all right, want to bring some help.

So, to reproduce that what i do

  1. run ibrowse
  2. click on "acube" fast link. it loads fine then i click on hyperion's fast link and it crashes. Crashlog attached

Changed 12 months ago by kas1e

comment:3 Changed 12 months ago by kas1e

To add , ignore DSI's help (at least on my peg2 setup), but after that in serial a have couple of:

Task 0x66D81DC0 (Shell Process) bad access @ 0xDEADBEEF, pc = 0x01821868, lr = 0x7F90FD54,

Changed 12 months ago by Kenwilde

comment:4 Changed 12 months ago by Kenwilde

Found my log-in info, I did the inital report, attached GR log from the X1000.

Changed 12 months ago by kas1e

comment:5 Changed 12 months ago by kas1e

@Thore

Also found that odyssey crashes too now (and that m_Application_NewInput.isra.42 are in crashlog too). I just enough to run odyssey, go to options, choice a bit and press "use" to have crash. It is skippable, but still. Attached

comment:6 Changed 12 months ago by tboeckel

  • Cc Kenwilde added
  • Component changed from undefined to Application.mui
  • Priority changed from undecided to normal

I tried to reproduce this myself using IBrowse 2.5 25.50 but it runs perfectly for me.

comment:7 Changed 12 months ago by tboeckel

In 3414:

  • Application.c, Window.c: reworked the input and event handler node handling to avoid accessing the global pointers as much as possible. This refs #23.

comment:8 Changed 12 months ago by tboeckel

  • Reporter changed from anonymous to Kenwilde

comment:9 Changed 11 months ago by tboeckel

  • Owner set to tboeckel
  • Resolution set to fixed
  • Status changed from pending to closed

In 3416:

  • Window.c: reverted r3347 as it caused more harm than good. This closes #23.

Changed 11 months ago by tboeckel

muimaster.library 20.6181

comment:10 follow-up: Changed 11 months ago by tboeckel

  • Component changed from Application.mui to Window.mui
  • Milestone set to MUI 4.0-2014R4
  • Release Notes modified (diff)
  • Severity changed from minor to blocker

Please try muimaster.library 20.6181. For me there are no crashes anymore.

comment:11 in reply to: ↑ 10 ; follow-up: Changed 11 months ago by Severin

Replying to tboeckel:

Please try muimaster.library 20.6181. For me there are no crashes anymore.

Still crashes here on my X1000

Changed 11 months ago by Severin

comment:12 follow-up: Changed 11 months ago by kas1e

@Thore
For me new muimaster.library for sure fix crashes with odyssey's preferences, and i didn't have also crashes in ibrowse too. Maybe for Severin it crashes because not only muimaster.library involved ? (as i also have yesterday's beta from you, maybe something else should be uploaded as well and not only muimaster.library?)

comment:13 follow-up: Changed 11 months ago by Kenwilde

Just tried muimaster.lib v20.6181, IBrowse still GRs for me on the x1000.

comment:14 in reply to: ↑ 12 Changed 11 months ago by tboeckel

Replying to kas1e:

maybe something else should be uploaded as well and not only muimaster.library?)

Why if all the relevant changes were in muimaster.library?

comment:15 in reply to: ↑ 13 Changed 11 months ago by tboeckel

Replying to Kenwilde:

Just tried muimaster.lib v20.6181, IBrowse still GRs for me on the x1000.

And why don't you provide a crashlog done with this version? Honestly, reporting a bug is more than just telling "it doesn't work".

comment:16 in reply to: ↑ 11 Changed 11 months ago by tboeckel

Replying to Severin:

Still crashes here on my X1000

Your crashlog points to the object pointer handling. Please disable this globally (MUI prefs -> System -> Object pointer types) and then try again.

comment:17 Changed 11 months ago by Kenwilde

Using the new muimaster.lib with object pointer type disabled, I still get a recoverable IB crash.

Crash log for task "IB"
Generated by GrimReaper 53.19
Crash occured in module IB at address 0x7F84EADC
Type of crash: DSI (Data Storage Interrupt) exception
Alert number: 0x80000003

Register dump:
GPR (General Purpose Registers):

0: 7F84EAD4 590A4B30 00000000 54CCC770 54CCC740 000000FE 590A48C8 590A48E8
8: 54D04474 000000F1 55940E20 02B10000 48842024 00000000 590A4F68 58F0BF68

16: 55DD0000 590A556C 55DD0000 55CE66C0 59843B40 00000000 54BB49B4 000002EC
24: 00000000 55940E20 00000080 0000017F 000002E1 000000FE 590A4DB8 5901C024

FPR (Floating Point Registers, NaN = Not a Number):

0: nan -2.15211e+307 -2.15211e+307 -2.15211e+307
4: -2.15211e+307 -2.15211e+307 1 1
8: 76 255 130 896

12: 914 1490 0 0
16: 0 0 0 0
20: 0 0 0 0
24: 0 0 0 0
28: 0 0 0 0

FPSCR (Floating Point Status and Control Register): 0x82004000

SPRs (Special Purpose Registers):

Machine State (msr) : 0x0200B030

Condition (cr) : 0x54F31D70

Instruction Pointer (ip) : 0x7F84EADC

Xtended Exception (xer) : 0x0000FFFF

Count (ctr) : 0x54A1AA64

Link (lr) : 0x59931D70

DSI Status (dsisr) : 0x54F31D90
Data Address (dar) : 0x02021130

680x0 emulated registers:
DATA: 00000001 00000000 00000000 00000000 00000000 00000000 00000000 00000000
ADDR: 6FFB8700 92C96E00 00000000 00000000 00000000 00000000 00000000 590A4160
FPU0: 0 0 0 0
FPU4: 0 0 0 0

Symbol info:
Instruction pointer 0x7F84EADC belongs to module "IB" (HUNK/Kickstart)

Stack trace:

module IB at 0x7F84EADC (section 5 @ 0xA7AB8)
module IB at 0x7F84EAD4 (section 5 @ 0xA7AB0)
native kernel module intuition.library.kmod+0x0001b0f0
native kernel module intuition.library.kmod+0x0001b294
native kernel module intuition.library.kmod+0x00008dac
native kernel module intuition.library.kmod+0x000089ec
m_Window_Input()+0x16cc (section 2 @ 0x7A0E4)
m_Application_NewInput.isra.42()+0x7c0 (section 2 @ 0x22A74)
ApplicationDispatcher()+0xd68 (section 2 @ 0x27ACC)
native kernel module intuition.library.kmod+0x0001b0f0
native kernel module intuition.library.kmod+0x0001b294
native kernel module intuition.library.kmod+0x00008c64
module IB at 0x7F8137D0 (section 5 @ 0x6C7AC)
native kernel module intuition.library.kmod+0x0001b0f0
native kernel module intuition.library.kmod+0x0001b294
native kernel module intuition.library.kmod+0x00008dac
native kernel module intuition.library.kmod+0x000089ec
module IB at 0x7F8726BC (section 5 @ 0xCB698)
module IB at 0x7F8BBF08 (section 5 @ 0x114EE4)
module IB at 0x7F8BC388 (section 5 @ 0x115364)
native kernel module dos.library.kmod+0x00025208
native kernel module kernel+0x00042510
native kernel module kernel+0x00042590

PPC disassembly:

7f84ead4: 2c030000 cmpwi r3,0
7f84ead8: 418200c0 beq- 0x7F84EB98

*7f84eadc: 8015fffc lwz r0,-4(r21)

7f84eae0: 7c031a78 xor r3,r0,r3
7f84eae4: 80010054 lwz r0,84(r1)

System information:

CPU

Model: P.A. Semi PWRficient PA6T-1682M VB1
CPU speed: 1800 MHz
FSB speed: 900 MHz
Extensions: altivec

Machine

Machine name: AmigaOne X1000
Memory: 2097152 KB
Extensions: bus.pci bus.pcie

comment:18 follow-up: Changed 11 months ago by Severin

Still get crashes with object pointer handling turned off.

Changed 11 months ago by Severin

comment:19 in reply to: ↑ 18 ; follow-up: Changed 11 months ago by tboeckel

Replying to Severin:

Still get crashes with object pointer handling turned off.

Please retry with bubble help turned off, too.

comment:20 in reply to: ↑ 19 Changed 11 months ago by Severin

Replying to tboeckel:

Please retry with bubble help turned off, too.

I always have bubble help set to 'when pressing a key', but I turned it off and still get the crash.

comment:21 Changed 11 months ago by Severin

I've also noticed that the auto reload on amigaworld doesn't work when you log in or post. I emailed the IB beta list about it and part of Olivers reply was:

From a technical perspective, the reload on
AW.net is a HTML meta refresh and IBrowse uses MUI's input handlers to
implement the refresh timer.

comment:22 Changed 11 months ago by Severin

Just noticed that gif anims no longer play in IBrowse either which is probably also timer related.

GifAn also no longer plays gifs. no matter what gif you load it reports only 1 frame, clicking the play button just switches between the first and second frame and stops.

Last edited 11 months ago by Severin (previous) (diff)

Changed 11 months ago by tboeckel

muimaster.library 20.6184

comment:23 Changed 11 months ago by tboeckel

muimaster.library 20.6184 fixes the non working GIF animation. Please let me know if it fixes the crashes and the non working reload in IBrowse as well.

comment:24 Changed 11 months ago by Severin

Confirmed that GifAn and IBrowse reload works. I still get a DSI though, Crashlog attached...

Changed 11 months ago by Severin

muimaster.library 20.6184 crashlog

comment:25 Changed 11 months ago by kas1e

I do test today ibrowse2.4 (that oem public come with os4) for about a hour on amiga related sites (just to avoid another crashes related to core), and still can't get crashes (but i have some beta version of whole mui from Thore dated back when i write post "all is fine for me and no crashes" ).

@Severin
Have you some stable reproducable test case for ibrowse, so i can try on my setup as well ?

comment:26 Changed 11 months ago by Severin

@kas1e

All I have to do is run IB2.5 on my X1000 and the crash happens within a few seconds when anything is opened, same for Ken with 2.4

comment:27 Changed 11 months ago by Kenwilde

Both Severin & I noticed that we can start IB & select a fast link, if we don't move the mouse, we get no crash. As soon as we move the mouse, we get the GR. Mabe that'll make sense to you guys. I let IB sit for 5 min & it crashed as soon as I moved the mouse.

comment:28 Changed 11 months ago by tboeckel

Finally I was able to reproduce this issue with IBrowse. But for me the crash only happened when the mouse was move over a link inside the browser, but not for the fastlink buttons at the top. And it happened only once. As soon as the crash happened once I could move the mouse over any other link without causing further crashes.

comment:29 Changed 11 months ago by tboeckel

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:30 Changed 11 months ago by tboeckel

  • Resolution set to fixed
  • Status changed from reopened to closed

In 3434:

  • Window.c: fixed another NULL pointer access when checking for possible bubble help texts. As it seems only IBrowse was affected and the crash happens only once for a running instance of IBrowse when moving the mouse over a link in the browser group. This closes #23 again.

Changed 11 months ago by tboeckel

muimaster.library 20.6185

comment:31 Changed 11 months ago by tboeckel

Everybody please check if muimaster.library 20.6185 fixes this issue. At least for me it does...

comment:32 Changed 11 months ago by Kenwilde

v20.6185 seems to have fixed the problem for me, do more testing tomorrow, thanks for your time & effort. :-D

I will inform Severin of the new lib so he can test when I see him in irc.

comment:33 Changed 11 months ago by tboeckel

  • Cc Severin added

comment:34 Changed 11 months ago by Severin

Seems to be fixed here too, great work, thanks :)

comment:35 Changed 12 days ago by tboeckel

  • Milestone changed from MUI 4.0-2014R4 to 4.0-2014R4

Milestone renamed

Note: See TracTickets for help on using tickets.

This list contains all users that will be notified about changes made to this ticket.

These roles will be notified: Reporter, Subscriber

  • Ken Wilde(Reporter, Subscriber, Participant)
  • Severin(Subscriber, Participant)