Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#222 closed bug (fixed)

MUI 4.0 does not run on WB 3.1

Reported by: thomas-rapp@… Owned by: Thore Böckelmann
Priority: normal Milestone: 4.0-2015R3
Component: muimaster.library Version: 4.0-2015R1
Severity: minor Keywords:
Cc: OS Platform: AmigaOS3
Blocked By: Blocking:
Release Notes:

Description

Summary

MUI 4.0 does not run on WB 3.1. It requires mathieeedoubbas.library version 39, but WB 3.1 only has version 38.

version libs:mathieeedoubbas.library file full

mathieeedoubbas.library 38.2 (24.01.92)

Steps to reproduce

  1. install MUI 4.0
  2. run mui:mui

Expected results

MUI preferences open

Actual results

output in the shell: unknown error (20)

SnoopDOS shows OpenLib mathieeedoubbas.library Ver 39 fail

no other fails (except muimaster.library as a result of the above)

Regression

revert to MUI 3.9

Notes

I don't know if it is intended that MUI 4.0 does not run on WB 3.1 because of some other requirements. But if math library version in OpenLibrary is the only obstacle, it would be a pity not to fix it.

Change History (2)

comment:1 Changed 4 years ago by Thore Böckelmann

Owner: set to Thore Böckelmann
Priority: undecidednormal
Status: newassigned

comment:2 Changed 4 years ago by Thore Böckelmann

Resolution: fixed
Status: assignedclosed

In 4796:

  • libheader.c: lowered the required version of mathieee#?.library from 39 to 38 to let MUI run on plain AmigaOS3.1 again. This closes #222.
Note: See TracTickets for help on using tickets.