Opened 4 years ago

Closed 4 years ago

#214 closed bug (fixed)

Folder Tabs GFX problem (cosmetic)

Reported by: Mikhail Malyshev Owned by: Thore Böckelmann
Priority: normal Milestone: 4.0-2015R2
Component: Title.mui Version: 4.0-nightly build
Severity: minor Keywords:
Cc: OS Platform: All
Blocked By: Blocking:
Release Notes:

Description

Summary

There is a small problems with how the updated folder tabs are draw now. Previously the Tab was connected as one part of the active folder. But now, depending on the type of frame used you get a line across the connecting section of the Tab. The situation is even worth for 2 pxl frames where only part of frame is drawn. Can we do something here ? so that the top part of the folder Tab properly connects to the page without this division line, as it was before.

Expected results

No division line for folder tab (when in classic tab mode)

Actual results

Different division lines depending on used frame

Attachments (2)

tabs.png (27.7 KB) - added by Mikhail Malyshev 4 years ago.
«Global».prefs (17.9 KB) - added by Mikhail Malyshev 4 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 4 years ago by Thore Böckelmann

Honestly, I have no clue what you are talking about. If you want to complain about something then you should make yourself as clear as possible. If words cannot describe your problem then perhaps a screenshot can.

Changed 4 years ago by Mikhail Malyshev

Attachment: tabs.png added

comment:2 Changed 4 years ago by Mikhail Malyshev

See the faint line under the tab title ?
In tab mode the top part needs to be combined with main body (used to be like that) But now it is separated and moving the tab up/down does not help much since artefacts still appear at intersections.

Same problem in OS3 and OS4
With any frame type

Last edited 4 years ago by Mikhail Malyshev (previous) (diff)

comment:3 Changed 4 years ago by Mikhail Malyshev

Interesting behaviour…. OS3
If you change the frame type, background for the main tab frame several times you are bound to reset the machine (no gurus or anything, just quick reset for no reason) not 100% reproducible, but has happened to me 4 times while playing with it today (doing nothing else).

comment:4 Changed 4 years ago by Thore Böckelmann

Again, no problem here. No matter which of the internal frames I choose for the register group or the tabs everything is always rendered correctly without any unwanted lines. Could you please provide a saved settings file which causes the trouble for you?

comment:5 Changed 4 years ago by Mikhail Malyshev

Tried with built in defaults, same problem.
The line is there even for frames without border!

Setting file attached just in case.

Changed 4 years ago by Mikhail Malyshev

Attachment: «Global».prefs added

comment:6 Changed 4 years ago by Mikhail Malyshev

UPDATE: found the only frames that works here (the new rounded corner ones)
they produce a correct linked container to tab image (no line).
And possibly this also connects to the bug 215 problem

comment:7 Changed 4 years ago by Thore Böckelmann

Thanks! With your settings I am finally able to reproduce this issue as well as #215. I'll see what is causing this.

comment:8 Changed 4 years ago by Thore Böckelmann

Component: undefinedTitle.mui
Milestone: 4.0-2015R2
Owner: set to Thore Böckelmann
Priority: undecidednormal
Status: newassigned

comment:9 Changed 4 years ago by Thore Böckelmann

Resolution: fixed
Status: assignedclosed

In 4775:

  • Title.mui: removed some artificial handling of even/odd height values which caused a horizontal line to be left visible for certain frame images. This closes #214.
Note: See TracTickets for help on using tickets.