Opened 6 years ago

Closed 6 years ago

Last modified 5 years ago

#20 closed bug (invalid)

Crash in MUIP_CreateDragImage() when drag some data in odyssey

Reported by: Roman Kargin Owned by:
Priority: normal Milestone: 4.0-2014R3
Component: foreign application Version: 4.0-2014R2
Severity: minor Keywords:
Cc: OS Platform: AmigaOS4
Blocked By: Blocking:
Release Notes:

Description

Summary

Sometime when you drag something in the webkit field of odyssey (i.e. in the main window area), it crashes in the MUIP_CreateDragImage(). It can't be reproduced very easy, but one time it happens for me when i just go to acid3.acidtests.org and trying to drag some image in. Another time it happens for Samo, when he trying to autoscroll with mouse, and, probably dbl-click somewhere so it start to do that dragging.

His report with crashlog:
http://bugs.os4depot.net/?function=viewissue&issueid=874

My crashlog attached.

As can be seen, crash the same in both cases and DAR about NULL always.

Attachments (1)

dragimage_crash.txt (7.8 KB) - added by Roman Kargin 6 years ago.
mui dragimage() crash

Download all attachments as: .zip

Change History (4)

Changed 6 years ago by Roman Kargin

Attachment: dragimage_crash.txt added

mui dragimage() crash

comment:1 Changed 6 years ago by Thore Böckelmann

Milestone: MUI 4.0-2014R3
OS Platform: undefinedAmigaOS4
Priority: undecidednormal
Resolution: invalid
Status: newclosed
Version: 4.0-2014R2

Well, the crash does not happen inside MUI code, but during the execution of your own implementation of MUIM_CreateDragImage. In fact it finally happens in Picasso96.

What am I supposed to fix here? It is your code that is faulty. The crashing function is definitely C++ code: _ZL26handleMUIM_CreateDragImageP6IClassPmP20MUIP_CreateDragImage()

There must be something wrong in owbbrowserclass.cpp DEFMMETHOD(CreateDragImage), because this is the only occurence of an overloaded MUIM_CreateDragImage method within Odyssey. MUIP_CreateDragImage is no function name, but the name of the structure passed as message to the method.

Use c++filt to demangle the cryptic C++ names to something readable:
c++filt _ZL26handleMUIM_CreateDragImageP6IClassPmP20MUIP_CreateDragImage
→ handleMUIM_CreateDragImage(IClass*, unsigned long*, MUIP_CreateImage*)

comment:2 Changed 6 years ago by Thore Böckelmann

Component: undefinedforeign application

comment:3 Changed 5 years ago by Thore Böckelmann

Milestone: MUI 4.0-2014R34.0-2014R3

Milestone renamed

Note: See TracTickets for help on using tickets.