Opened 5 years ago

Closed 5 years ago

#192 closed bug (fixed)

MCC LayGroup 19.2 crash under MUI4

Reported by: Samir Hawamdeh Owned by: Thore Böckelmann
Priority: normal Milestone: 4.0-2015R2
Component: Frimagedisplay.mui Version: 4.0-nightly build
Severity: minor Keywords:
Cc: OS Platform: AmigaOS4
Blocked By: Blocking:
Release Notes:

Description

Summary

The old MCC LayGroup 19.2 (68k) crash badly under MUI4 (AmigaOS4)

http://sourceforge.net/projects/laygroup-mcc/

Steps to reproduce

  1. Just copy the class files
  2. Start MUI and select the class from the prefs

Expected results

Should work :-)

Actual results

It doesn't !

Attachments (1)

Crashlog_MUI_2015-04-11_09-14-53.txt (26.2 KB) - added by Samir Hawamdeh 5 years ago.

Download all attachments as: .zip

Change History (4)

Changed 5 years ago by Samir Hawamdeh

comment:1 Changed 5 years ago by Thore Böckelmann

In 4644:

  • muiprog.h, Frimagedisplay.c: added a NULL pointer check for possibly invalid frame specs. This refs #192.

comment:2 Changed 5 years ago by Thore Böckelmann

Component: foreign classFrimagedisplay.mui
Milestone: 4.0-2015R2
Owner: set to Thore Böckelmann
Priority: undecidednormal
Status: newassigned

comment:3 Changed 5 years ago by Thore Böckelmann

Resolution: fixed
Status: assignedclosed

In 4646:

  • Frimagedisplay.c: reject invalid frame specs (i.e. normal frame definitions like MUIV_Frame_XXX) to avoid accessing invalid pointers. This closes #192.

Note: this is not a bug in MUI but in ancient classes whose developers thought they were smarter than others and simply used wrong values.

Note: See TracTickets for help on using tickets.