Opened 4 years ago

Closed 4 years ago

#178 closed bug (fixed)

Crash using arrows in NewStuff/Title.mui

Reported by: Samir Hawamdeh Owned by: Thore Böckelmann
Priority: normal Milestone: 4.0-2015R2
Component: Title.mui Version: 4.0-nightly build
Severity: minor Keywords:
Cc: OS Platform: AmigaOS4
Blocked By: Blocking:
Release Notes:

Description

Steps to reproduce

  1. Open NewStuff/Title.mui
  2. Open a few tabs until the arrows will be showed
  3. Right click on the arrows —> crash

Tested with MUI4 svn r4609

Attachments (1)

Crashlog_NewStuff_2015-03-12_03-26-21.txt (30.5 KB) - added by Samir Hawamdeh 4 years ago.

Download all attachments as: .zip

Change History (6)

Changed 4 years ago by Samir Hawamdeh

comment:1 Changed 4 years ago by Thore Böckelmann

Milestone: 4.0-2015R2
Owner: set to Thore Böckelmann
Priority: undecidednormal
Status: newassigned

comment:2 Changed 4 years ago by Thore Böckelmann

In 4613:

  • Title.c: do the relayout after readding the temporarily removed scroll buttons to make sure they don't get accessed while they are not part of the GUI. This refs #178.

comment:3 Changed 4 years ago by Thore Böckelmann

Please check if this issue is fixed with the next nightly build. I am not near any AmigaOS4 machine right now, but on AmigaOS3/WinUAE I don't get a crash or invalid memory access anymore.

comment:4 Changed 4 years ago by Samir Hawamdeh

This specific problem seems fixed now, you can close this ticket :-)

However as i mention the latest modifications in the Title class have worsened the graphical effect of the opening/closing of the tabs: ticket #15

Now anytime you open/close a tab in Odyssey, even a blank one the glitch are pretty visible, also you can note a certain slowdown during the operation, atleast a full second to close a tab or just for opening a new one

In short while before the issue was not so important, aka it was visible only in case you had 2 tabs (and you close one in order to remain with a single tab opened) —> reproducible only activating the "hide single" tab option

Now the problem is present anytime you open/close a tab, so now it become an important issue

comment:5 Changed 4 years ago by Thore Böckelmann

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.