Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#148 closed bug (invalid)

Busy.ncc

Reported by: Mikhail Malyshev Owned by:
Priority: normal Milestone: 4.0-2015R1
Component: Busy.mcc Version: 4.0-AmiKit8.2
Severity: minor Keywords:
Cc: OS Platform: AmigaOS3
Blocked By: Blocking:
Release Notes:

Description

Busy/Prefs/Direction

Cannot change direction of scrolling for busy mode
The button displays Right / In|Left / Out
and has no effect.

Attachments (1)

transifex_russian.png (203.6 KB) - added by Thore Böckelmann 5 years ago.
Russian translation in transifex

Download all attachments as: .zip

Change History (9)

comment:1 Changed 5 years ago by Thore Böckelmann

Milestone: MUI 4.0-2015R1
Priority: undecidednormal
Resolution: invalid
Status: newclosed

The two options "right/in" and "left/out" must be separated by a pipe character ("|", hex 7c). Make sure to use the correct characters in your translation. Your translation "Вправо / Влево / Наружу" is definitely wrong and is missing the pipe character.

comment:2 Changed 5 years ago by Mikhail Malyshev

Ok fixed, but the example text is wrong, since it has slashes and no pipes

comment:3 Changed 5 years ago by Thore Böckelmann

Read my first answer again. There are just two options, and yes, each option contains a slash. But the two options are separated by a pipe character. If you cannot believe it then install the old Busy.mcc (http://aminet.net/dev/mui/MCC_Busy2_4.lha) and see for yourself how the options looked like back then.

comment:4 Changed 5 years ago by Mikhail Malyshev

I know how it works and worked.
The problem is that the transifex string is with slashes only, no pipes
This makes translators confused and unaware of the issue

comment:5 in reply to:  4 Changed 5 years ago by Thore Böckelmann

Replying to Michael:

The problem is that the transifex string is with slashes only, no pipes

Wrong. At least for me the pipe character is visible, see screenshot. I admit it can be overseen quite easily, but that that depends on the font used in the web browser.

Changed 5 years ago by Thore Böckelmann

Attachment: transifex_russian.png added

Russian translation in transifex

comment:6 Changed 5 years ago by Thore Böckelmann

By the way, your current translation is still wrong. As you can see in the screenshot you created a string consisting of 3 options instead of just 2.

Again, there are only two options and their english representation is:
Right/in
Left/out

Each option consists of a slash character and both options are separated by a pipe character.

comment:7 Changed 5 years ago by Mikhail Malyshev

Must be a bad day
I think it's correct now ;-)

comment:8 Changed 5 years ago by Thore Böckelmann

Milestone: MUI 4.0-2015R14.0-2015R1

Milestone renamed

Note: See TracTickets for help on using tickets.