Opened 6 years ago

Closed 6 years ago

Last modified 5 years ago

#122 closed bug (invalid)

Reboot when using WOSPrefs and Trident

Reported by: ancalimon Owned by:
Priority: normal Milestone: 3.9-2015R1
Component: muimaster.library Version: 3.9-2014R3
Severity: minor Keywords:
Cc: OS Platform: AmigaOS3
Blocked By: Blocking:
Release Notes:

Description

Summary

MUI 39r4 causes reboot when you move your mouse over WOSPrefs window. It also causes reboot when you open the Action tab using the program Trident (the prefs program of Poseidon)

Steps to reproduce

1.Run http://aminet.net/package/util/misc/WOSprefs and move your mouse over its window or click cancel on its window.

2.Run Trident, click devices, double click on a hid device, double click on the mouse class, click the Action tab.

Expected results

It should not reboot

Actual results

It reboots

Regression

Notes

I could not reply to the bug report I created earlier.

Change History (9)

comment:1 Changed 6 years ago by ancalimon

Version should have been 3.9-2014R3. Sorry about the typo.

Also it seems like this time I can reply using the add comment function.

comment:2 Changed 6 years ago by Thore Böckelmann

Neither WOSprefs not Trident crash for me. The context help of WOSPrefs is updated correctly for each item in the window and also clicking "Cancel" does not cause any harm.

For Trident I cannot tell more than just "it works", because I have no supported hardware available on my WinUAE system and hence cannot open the Action tab you mentioned.

Please run the usual debugging tools like SegTracker, WipeOut, Enforcer, etc before starting the affected applications. Without any more detailed information than "it crashes" I cannot help you.

To exclude any side effects of old preferences you can also try to rename your ENVARC:MUI directory and reboot before starting WOSPrefs or Trident again. Perhaps there are some old settings which trigger unwanted effects.

comment:3 Changed 6 years ago by Thore Böckelmann

You also should check the stack size of both programs. For WOSPrefs it defaults to 8K which might be a bit too tight. Better use at least 32K.

comment:4 Changed 6 years ago by Thore Böckelmann

Ticket #116 has proven that a stack size of 32K cures certain crashes. Hence I recommend to raise the stack size of the affected applications accordingly.

comment:5 Changed 6 years ago by ancalimon

I just realized I forgot installing stackattack after setting up my Amiga. Installed it back and WosPrefs and Trident no longer crash!

stackattack is a really important program. Without it no Amiga is stable. :)

comment:6 Changed 6 years ago by Mikhail Malyshev

StackAttack just hides potential problems by automatically setting a much higher stack then usually required, when you have everything setup properly (including stacks for tools and patches) everything works fine with out it.

comment:7 Changed 6 years ago by Thore Böckelmann

Component: undefinedmuimaster.library
Milestone: MUI 3.9-2014R4
Priority: undecidednormal
Resolution: invalid
Status: newclosed

I assume this ticket can be closed then. The current nightly builds also have a simple stack size check implemented to make sure that the stack size is at least 32K.

comment:8 Changed 6 years ago by Thore Böckelmann

Milestone: MUI 3.9-2014R4MUI 3.9-2015R1

Milestone renamed

comment:9 Changed 5 years ago by Thore Böckelmann

Milestone: MUI 3.9-2015R13.9-2015R1

Milestone renamed

Note: See TracTickets for help on using tickets.