Custom Query (407 matches)

Filters
 
Or
 
  
 
Columns

Show under each result:


Results (133 - 135 of 407)

Ticket Resolution Summary Owner Reporter
#134 fixed Hide Single Tabs option - adding/deleting Pages when Clicktab is not currently visible Thore Böckelmann Richard Lake
Description

Summary

I have given you a link below to an executable of my new MUI Builder application as this is a much better way to explain the problem.

http://www.lakemarketing.co.uk/jack_uploads/MUIBuilder

Hopefully the EXE will open as is you won't need any dependancies, if something is missing please do let me know.

Steps to reproduce

  1. In MUI Settings turn on Groups/Hide Single tab.
  1. Run the MUIBuilder application, on the second tab, you can Add new windows to the interface, doing so adds a listitem to the above listview the code also adds a Tab to the interface. This new Tab be found under the main tab list titled Layout.
  1. Now return to the Windows tab, now delete all the Windows apart from the one at the top which is not allowed to be removed. As you delete the second tab to leave one remaining the screen corrupts as per the screenshot shown.
  1. At this point, adding pages to the interface also causes the application to exhibit incorrect behaviour.

Expected results

Screen not to corrupt when Closing/deleting pages of a Clicktab gadgets which is currently out of view when the MUI Setting 'Hide single tab' is enabled. Looks like an oversight.

Actual results

GUI corruption. See attached screenshot.

Regression

Notes

I hope this makes sense.

#41 fixed Hits - mesa.mcc Thore Böckelmann mm@…
Description

Summary

On first opening MUI-Prefs/External - mesa.mcc item we get a hit After it works ok, no hits. (using d1plus video driver)

06-Jul-14  21:20:05
WARNING: ENFORCER HIT!                                                        
BYTE-READ from 00000062                  PC: 44A3ECB4
USP:  44FB88D8 SR: 0000 FLSW: 01210200 TCB: 44FA92F8
Data: 0000005F 00000003 44FB88FC 0000000F 44FB89E4 44B11EB0 44B53D80 44FB8A68
Addr: 00000062 00000000 455DE760 455E0B00 450F2148 455E0BF0 449A1A50 44FB88D8
Stck: 449EF092 00000062 0000005F 00000000 449A1A50 449EDD60 44F64CF0 00000000
Stck: 450F6FE8 00000062 44F64D4C 450F754C 44FB89D0 44F64CF0 455E0DF8 455E0978
Stck: 455DAC80 455DF4B0 455CA428 455DE5E0 44F64D4C 44FB89C4 44F64D4C 44FB7465
Stck: 73740000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
----> 44A3ECB4 - "LIBS:muimaster.library" Hunk 0000 Offset 0005C75C
----> $44a3ecb4: MOVE.B    (A0),D1
----> $44a3ecb6: CMP.B     D1,D0
----> $44a3ecb8: BNE.S     $44a3ecbe
----> $44a3ecba: MOVE.L    A0,A1
----> 449EF092 - "LIBS:muimaster.library" Hunk 0000 Offset 0000CB3A
----> $449ef092: MOVE.L    D0,A0
----> $449ef094: ADDQ.L    #$8,A7
----> $449ef096: TST.L     A0
----> $449ef098: BEQ.S     $449ef0b2
----> 449EDD60 - "LIBS:muimaster.library" Hunk 0000 Offset 0000B808
----> $449edd60: BRA.S     $449edd64
----> $449edd62: CLR.L     D0
----> $449edd64: MOVE.L    (A7)+,D2
----> $449edd66: MOVE.L    (A7)+,D3
----> 450F6FE8 - "LIBS:mui/Mesa.mcp" Hunk 0000 Offset 00001190
----> $450f6fe8: LEA       $0004(A7),A7
----> $450f6fec: MOVE.L    D0,$0010(A2)
----> $450f6ff0: CLR.L     -(A7)
----> $450f6ff2: PEA       $450f6140(PC)
----> 450F754C - "LIBS:mui/Mesa.mcp" Hunk 0000 Offset 000016F4
----> $450f754c: MOVE.L    A4,-(A7)
----> $450f754e: MOVE.L    (A1),D0
----> $450f7550: SUBI.L    #$80425242,D0
----> $450f7556: LEA       $450f2148.L,A4
Name: "MUI"
#293 invalid Horizontal Group Has Content Partially Hidden in MUI v4, Not MUI v3.8a tygre
Description

Summary

The preferences page of AmiModRadio shows an HGroupV containing a Label2 and a TextObject. Under Workbench 3.1 and MUI v3.8, the height of this group is correct and the content of the HGroupV is shown entirely.

Under AmiKit 8.2 and MUI v4, the height of the group seems incorrect: the content of the HGroupV is partially hidden.

Steps to reproduce

Here is the code of the HGroupV, the complete source code is available at https://bitbucket.org/tygre/amimodradio/src/d96566b5ae399f7726c01e138c5eea3fa8c333c7/mui.c?fileviewer=file-view-default

Child, HGroupV,

Child, Label2("Saved modules directory:"), Child, TextObject,

MUIA_HelpNode, "TX_label_modules", MUIA_Background, MUII_TextBack, MUIA_Frame, MUIV_Frame_Text, MUIA_Text_Contents, prefs_get_saved_modules_directory(), MUIA_Text_SetMin, TRUE,

End,

End,

Expected results

A screenshot of the expected results under both MUI v3.8 and MUI v4 is available at http://www.chingu.asia/wiki/userfiles/image/Programming/AmiModRadio/160301%20-%20Prefs%20v0.97%20MUI%20v3.8.png

Actual results

A screenshot of the results under MUI v4 is available at http://www.chingu.asia/wiki/userfiles/image/Programming/AmiModRadio/160301%20-%20Prefs%20v0.97%20MUI%20v4.png. Also, a movie showing that the content of the HGroupV can be shown using the mouse wheel is available at https://www.dropbox.com/s/cd3rawk2zrt1rla/2016-02-14%2000.18.10.mov?dl=0 (Jan Zahurancik's courtesy).

Regression

I would think so.

Notes

Maybe my code is responsible for the problem, please let me know!

PS. It seems that the problem comes from nesting virtual group (a HGroupV inside another VirtualGroup), I will test soon on Amikit…

Note: See TracQuery for help on using queries.